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1 The basics

1.1 Why LaTeX?
e The basic idea of LaTeX documents: you do as little formatting as possible!!
e [t is standard in economics (and many other disciplines) because:

— It looks professional
« This has additional value for PhD students and junior faculty
x Enables easier co-authoring relationships
— It makes things easy
x Well, at least with WYSIWYG editors like LyX!
x Equation writing ability
* Equation numbering/cross-referencing

« Citations/bibliographies

e You can find the latest version of this file, and any associated materials, on my website.

The

1.2 Getting LaTeX up and running

e “LaTeX” is really a combination of the back end installation of LaTeX, a front end

LaTeX editor used to write documents, and BibTeX for bibliographic references.

1. Programs that manage/install the back end of LaTeX include MikTeX or TeX
Live.


http://p2.smu.edu/jlake/data_code.html
https://miktex.org/download
https://www.tug.org/texlive/
https://www.tug.org/texlive/

— This is the program you’ll use to add “packages” to your LaTeX installation

so you can use them in your LaTeX documents.

— You really want a “complete” LaTeX installation so that it comes with most
packages, if not all, packages that you’ll need. So, pay attention for this
option during the TeX Live install process. With the above MikTeX link,
it brings you to the basic Windows installation file. Go across to the “All
downloads” tab and install the “Net Installer” version which is the complete

install version.
2. There are generally two types of LaTeX editors
— “Native” LaTeX editors where you write all of the LaTeX code yourself. This

includes programs like TeXworks (probably will be automatically installed
when you install TeX Live or and TeXmaker. Overleaf is an online example,
so no need to install anything as long as you’'re working online all of the time;
you'll need to install LaTeX as described above if you want to use it when

offline.

— WYSIWYG LaTeX editors. This includes LyX (free) and Scientific Word
(expensive). These have the advantage that you don’t have to write your
own LaTeX code.! Using LyX is a very easy place to start!!! It’s what I
used as a PhD student and what I still use today for many things (I also use
Scientific Word a lot, but that’s just because my co-authors do). I have never

written a paper in a native LaTeX editor.

3. “BibTeX” is the LaTeX version of how to keep a bibliography database. It really

has two parts.

— Technically, BibTeX is actually part of the back end LaTeX installation and
it will already be installed with your LaTeX installation described above. It
will take care of all citation/bibliography formatting. Never do this manually
ever again!

— You need to use a different program to create the actual file of references that
will be used in your LaTeX documents by BibTeX. JabRef is a WYSIWYG
program that does this. You should store every paper you ever cite in here!

x Use Google Scholar to copy and paste the bibliography information into

JabRef! You will only do this once for any paper you ever cite!

!Many people used Scientific Word 5. At least the initial versions of Scientific Word 6 were not very good
at switching between LaTeX and Scientific Word users which is problematic when co-authoring. I'm not
sure if this has been fixed. I still use Scientific Word 5 because of it.


https://www.overleaf.com/for/authors
https://www.lyx.org/Download
https://www.mackichan.com/index.html?products/sw.html~mainFrame
https://www.jabref.org/

1.3 Writing a paper

Let’s walk through a short simple example of a paper in LyX: title, author & institution,
intro (with automatic section references), model (with multiple automatically numbered and
cross-referenced equations), a bibliography reference, conclusion, and reference list. See

Section 2.1 for some additional guidance on getting started writing papers using LaTeX.

e Default “document class” in LyX is “Article (standard class)” which is what you want

for writing papers. (Document -> Settings -> Document Class)

— The example we did is here in its Lyx file .lyx and its LaTeX file .tex obtained by

exporting from Lyx (see below).

— For the BibTeX part of the file, you’ll need the bibtex .bib file that has all of the

papers you can cite.

Basic formatting: margins, line spacing, font size

— I like 1 inch margins all around, 12 pt font and one-and-a-half line spacing. This
seems common too. (Document -> Settings -> Font (font size)/Text Layout (line

spacing)/Page margins (margins))

— Remember the basic idea of LaTeX: you do as little formatting as possible!

You need to “compile” your document to see it in PDF (the “eyes” symbol top left in
LyX).

— In LyX, you also need to manually save the PDF!! Many editors do this auto-
matically when compiling your PDF.

e You can export your LyX file with extension .lyx to a LaTeX file with extension .tex
(File -> Export -> LaTeX (plain))

— A great LaTeX cheat sheet!

— You can also import .tex files that anyone has written using native LaTeX editors

(File -> Import)

e You can view the LaTeX source code in Lyx at the bottom of the screen (View ->

Code Preview Pane)

— Another great LaTeX cheat sheet!

Installing and using packages


https://www.dropbox.com/s/bhe0fuhmyyffuxx/paper061621.lyx?dl=0
https://www.dropbox.com/s/etxakhls05q4ioc/paper061621.tex?dl=0
https://www.dropbox.com/s/s9fy17o4hjoqk7z/referencesMaster.bib?dl=0

— You can add various “packages” using your LaTeX back end package to make them

available in your LaTeX editor.
— You often use the “preamble” to tell your LaTeX document that you want to use

a special package. (Document -> Settings -> LaTeX Preamble)

e “Official” SMU dissertation LaTeX template.

1.4 Making a presentation (beamer)

e Beamer is the LaTeX version of Powerpoint slides. It’s already installed with the rest

of your LaTeX installation.

— Change document class to “Beamer” under “Presentations”. (Document -> Set-
tings)
— Even if you use a native LaTeX editor for writing papers, a WYSIWYG LaTeX

editor is very helpful for presentations.

* The LaTeX coding for presentations is much more tedious and prone to coding

€rrors

e The example we did is here in its Lyx file .lyx and its LaTeX file .tex obtained by
exporting from LyX.

e You can see the variety of slide styles here.

— The “y-axis” is the “theme” and the “x-axis” is the “color scheme”. To move
away from the default theme and color scheme, you enter this here in the LaTeX

preamble via Document -> Settings -> LaTeX Preamble.

— This screenshot example just changes the theme and leaves the color theme as
default.

x If you want to also change the color scheme to, say, Beaver then you’d add

\usecolortheme{beaver} on a new line.

e Let’s walk through a short simple example: title slide (title, author, institution), first
slide, second slide (with multiple numbered equation and cross-referenced equations).
See Section 2.2 for some additional guidance on getting started making presentations

using LaTeX.

— Separator between slides in LyX (get to “standard” and press “enter”)!


https://github.com/matthewfeickert/Dedman-Thesis-Latex-Template
https://www.dropbox.com/s/dxhfsqqaq1yyi5m/demoPresentation.lyx?dl=0
https://www.dropbox.com/s/bl90pw8xvcl5owv/demoPresentation.tex?dl=0
https://hartwork.org/beamer-theme-matrix/
https://www.dropbox.com/s/jbbhwrqjctmaddk/beamerStylePreamble.png?dl=0

e You need to compile your document

— Remember, in LyX, you need to manually save the PDF!!
— If you can’t compile, my experience says it’s nearly always for one of two reasons:

x The “begin frame” and “end frame” sequence has gotten messed up

% Going to deep with itemize. You can not nest more than three levels deep.

e You can view the LaTeX source code in Lyx at the bottom of the screen (View ->

Code Preview Pane).

e You can again export your LyX file with extension .lyx as a LaTeX file with extension
tex (File -> Export)

1.5 Bibliography references (bibtex)

e Here is an example: LyX, LaTeX and the “BibTeX file”. It’s here in PDF.
e Getting your BibTeX file set up in Lyx

— Insert -> List/TOC -> Bib(La)TeX Bibliography
* “Add” your .bib file that you created using JabRef above

x The default “style” will be “plain”. But, this is a numbered citation system
(e.g. “It has been shown, e.g. [1], that...”) rather than the author-year citation
system we use in econ (e.g. “It has been shown, e.g. Lake (2021), that...”).
So you should choose something that is an author-year style. Personally, I

like “elsarticle-harv”. But, there are many others.
— Document -> Settings -> Bibliography

% “Style format” should be “Natbib (BibTeX)”. “Variant” should then default to
“Author-year”.

— Insert a reference into your paper: Insert -> Citation
e When using a native LaTeX editor like TeXworks or TeXmaker:

— You’ll need to do go through a few steps to get your citations working properly.
You need to compile using pdfL.aTeX and then compile your bibTeX file and then
compile again, perhaps multiple times, using pdfLaTeX. You do all of this using

the drop down menu next to the play button (see here).


https://www.dropbox.com/s/7raq7nfsynbat9z/paperBasics.lyx?dl=0
https://www.dropbox.com/s/75kvoh16y1q7wq1/paperBasics.tex?dl=0
https://www.dropbox.com/s/s9fy17o4hjoqk7z/referencesMaster.bib?dl=0
https://www.dropbox.com/s/s2m74hz804neizn/paperBasics.pdf?dl=0
https://www.dropbox.com/s/0e56kkg1w0ur3km/bib5.png?dl=0

— Here’s a simple example that shows various styles of citations you can use in your
paper.
— Your native LaTeX editor will look for your .bib file in the same folder as your
tex file.
o A few tips:

— In JabRef, author initials need to have a “.”. Otherwise, LaTeX will crash when
compiling because it can’t interpret what’s an initial and what’s a name. For
example, “Blau, Francine D and Koebe, Josefine and Meyerhofer, Pamela A”

needs to be “Blau, Francine D. and Koebe, Josefine and Meyerhofer, Pamela A.”

— After updating your .bib file with new references in JabRef, you need to save that
file so that LyX (or any other LaTeX) editor recognizes the new references you've
added.

1.6 CV

See Section 2.3.

2 A few extensions

2.1 DMore on writing a paper

e See this Lyx file, LaTeX file, and the bibTex file hyperlinked above. Here it is in PDF.

e Title page (no number, “acknowledgments” footnote) is different from first page (num-
bered as 1).

e Hyperlinks/bookmarks and colors

— Hyperlinks: Document -> Settings -> PDF Properties. Check the “Use Hyperref
Support” box. This will create hyperlinks and also create the clickable “bookmark”

links on the left hand side of the compiled PDF for the sections of your paper.

— Change colors for hyperlinks: Document -> Settings -> LaTeX Preamble and see

the relevant code here.

e Propositions (and no indentations in LaTeX).


https://www.dropbox.com/s/qat8nz0b2s3136g/bibtexClassTex.zip?dl=0
https://www.dropbox.com/s/7raq7nfsynbat9z/paperBasics.lyx?dl=0
https://www.dropbox.com/s/75kvoh16y1q7wq1/paperBasics.tex?dl=0
https://www.dropbox.com/s/s2m74hz804neizn/paperBasics.pdf?dl=0
https://www.dropbox.com/s/0xmqtjtom7rwnmk/bib6.png?dl=0

— Document -> Settings -> Modules to “load” the relevant theorem-related format-
ting options. You then access them from the menu in the top left corner that

inserts sections, bullet points etc.

— LaTeX will often interpret the sentence after equations, Propositions, Lemmas
etc. as a new paragraph even though you don’t want it to be a new paragraph.
To fix this you need to use the TeX code \noindent. See here for LyX. Note that

you need a space between the LaTeX code and your sentence.
e Appendices

— Document -> Start Appendix Here (alternatively, in the above referenced LyX
and LaTeX files, I wrote out the TeX code \appendix).

— Then use the TeX code \renewcommand{\ thesection}{\ Alph{section}} to change

section “numbering” to letters as is typical for appendices.
e Empirical tables in LaTeX

— Personally, this is where I draw the line for LaTeX vs typical Microsoft packages.
I always export my STATA tables to text log files and then use Excel to format

them how I want. I then save/print as PDF from excel.
— However, there are various ways to go from your STATA output to LaTeX code.
x For a very good, recent and detailed explanation see this excellent guide by
Asjad Naqvi on Medium.

x There is also this website where you can either import a CSV file or just copy
and paste data from a spreadsheet (e.g. excel), text document, markdown
and the website will convert it into LaTeX code that you can copy and paste
into your LaTeX document. See the end of this LaTeX file based on the above
website where I copied and pasted data from excel into the website and then

copied and pasted the LaTeX generated code into a native LaTeX editor..

2.2 More on making presentations
e See here in LyX and here in LaTeX and here in PDF.
e Qutline slides

— As you can see in the .lyx and .tex files, you need to create a slide and use
the TeX code \tableofcontents|| for the full table of contents or \tableofcon-

tents[currentsection| so that just the current section is highlighted.
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https://www.dropbox.com/s/qt2jl71brk8c812/noIndent.png?dl=0
https://medium.com/the-stata-guide/the-stata-to-latex-guide-6e7ed5622856
https://www.tablesgenerator.com/latex_tables
https://www.dropbox.com/s/kju4xvu5fukkbxa/paperBasics_table.tex?dl=0
https://www.dropbox.com/s/dwve9isszdpleo6/presentationsBasics.lyx?dl=0
https://www.dropbox.com/s/6da6m56lu80gufo/presentationsBasics.tex?dl=0
https://www.dropbox.com/s/dndu5gnnc3d9uvj/presentationsBasics.pdf?dl=0

e Buttons

— As you can see in the .lyx and .tex files, you need to do a few things:

* On the slide where you want your “go forward button” and “go back” buttons,

use TeX code to start and end the slide: \begin{frame}{TypeTitleOfSlideHere}
and \end{frame}.

Edit the begin frame code on these two slides to give the slides a “label”. This
is needed so that LaTeX knows which slide to jump to when clicking on but-
tons. You edit the begin frame code to
\begin{frame}[label=TypeSlideLabelNameHere|{ TypeTitleOfSlideHere}.

In the place on the slide where you want the button, use the TeX code: \ hy-
perlink{LabelNameForGoToSlide}{\ beamergotobutton{ButtonLabel}}. This

will create a button with “ButtonLabel” on it and clicking on it will take you
to the slide with the label “LabelNameForGoToSlide”.

e Figures (diagrams can be found here). You can insert png files into LyX: Insert ->

Graphics (LaTeX will convert to eps files in the background upon compilation.)

— To center a figure in LyX, use Insert -> Formatting -> Horizontal Space ->
Horizontal Fill on both sides of the figure.

e Sometimes you might want to add your university logo to your slides. I've never done

this before, but here is a good discussion of how to do this using TeX code. If using

LyX, you’d need to combine this code with the above discussion on how to use TeX

code to start and end your slide.

2.3 Making a CV

e ['ve been using the same CV template since I was a PhD student because our cohort

was all told to use the template when we were on the job market! I now tell all of our
SMU job market PhD students to use this template too.

e The template from when I was a PhD student on the job market is here in .tex and

PDF.

— You need to put the LaTeX class file res.cls in the folder with your CV .tex file. A

LaTeX class file is a file that contains various formatting instructions for LaTeX.

For example, standard class files in LaTeX are the ones for making a paper and

making a beamer presentation.


https://www.dropbox.com/sh/narza5f5h70r5a7/AADB8oBVvTUA4ltvqNnKgGNHa?dl=0
https://tex.stackexchange.com/questions/27906/positioning-logo-in-the-front-page-as-well-as-slides
https://www.dropbox.com/s/yoplhe74xlzjev5/cvlakejw.tex?dl=0
https://www.dropbox.com/s/ht647vw1jgotyhb/CVLakeJW.pdf?dl=0
https://www.dropbox.com/s/8gc0win2sz7pou8/res.cls?dl=0

— I have only ever used this in a native LaTeX editor and never in LyX.

e The slightly different template which I now update periodically as a faculty member
is here in .tex and PDF.


https://www.dropbox.com/s/0nn57csf6h4mge6/CVLakeJW_032021.tex?dl=0
https://www.dropbox.com/s/qm4yl76gbrltn3j/CVLakeJW_032021.pdf?dl=0
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